Debugging the Smart Terminal

From OpenCircuits
Jump to: navigation, search

This page is designed to help with issues when the Smart Terminal seems not to be running or running properly.

Contents

Overview

The following comes from my and other's experiences in trying to get the terminal running. Hope this helps. If not let me know at: User:Russ_hensel

Missing Modules

Symptoms

Python complains about modules not found.

Fix

Find and install the modules, sometimes this may be caused by errors in the download package. If unsure contact me User:Russ_hensel.

Runs, Nothing Happens

Symptoms

Ran the program from command line or console and after starting we see something like "running mainloop", but nothing else happens.

Fix

Look around your computer's windows, the SmartTerminal may open in the background. It would be good to fix this in the app, there is a patch now, but may not always work.

Terminal Starts, Arduino Does not Respond

Symptoms

You send out data, but get nothing back, you have your reasons to believe that the arduino is working OK. Or you are getting data back but it is gibberish.

Fix

The terminal lets you send data to nowhere, if the port is not open, so make sure it is open ( look at the status display, use the open button ). If the port is open it may still be running at the wrong baud rate. Check the status display for the baud rate and use the parameter file ( you can access from the parameter button ) and set to the desired baud rate. There are also other comm settings, if you are still having trouble check them all.

Lack of Error Messages

Symptoms

Things not working, but no error messages in the console.

Fix

There may be the messages you are looking for in the log file. Use the GUI button to edit the log, or track down its name in the parameter file and then edit it.

Personal tools
Namespaces

Variants
Actions
Navigation
Toolbox